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RT Spread Scanner service is a professional tool for scanning equity option universe for profit 
opportunities. It covers the most popular strategies, from plain naked or covered strategies and 
conversions to more sophisticated spreads, straddles and strangles. Intuitive, but flexible interface 
makes the service suitable for both novice and advanced users. 
 
The scanner features: 
 

• Instruments coverage – all US publicly traded options (170,000+ listed contracts) 
• Real-time or 20-minute delayed data subscription modes  
• Scanning by risk/reward, risk/capital required, maximum return and probability of profit 
• Real-time position risk scenario simulation; includes short leg assignment risk simulation  
• Filtering by stock sentiment (using IVolatility.com ‘Stock Sentiment’ service data) 
• Ability to use custom stock lists (using IVolatility.com ‘Favorite’ groups) 
• Fine-tuning stock and option filters 

 

Quick overview 
 
When you open the service for the first time, you'll see the following Search screen: 
 



 
 
You can change the strategy here (Long Straddle by default) and number of contracts (10 by default, 
meaning contract on 10 x 100 = 1000 underlying shares). Default sorting is by Risk to Reward ratio 
(Risk / Reward), so you'll see less risky trades on top. "Less risky" here stands for "low max risk to 
max profit ratio" trades. Other possible sortings are:  
 

• by Capital Required - that is, by initial investment in $ 
• by Risk/Cap Req - by Risk to Capital Required ratio 
• by Max return - by maximum return of the trade 
• by Probability of Profit - by how probable is the "win" scenario for the trade 

 
All the other filters are hidden by default - see the Stocks, Options, Risk/Reward and Greeks groups 
below. You can expand any and all of these groups by pressing the orange arrow button to the left. 
For example, let's see how Stocks and Options filters are set for Long Straddle strategy by default: 
 

 



 
 
As you see, by default we are going to scan all US publicly traded equity with expected volatile 
behavior, but having cheap options (cheap IV Index). Options to be selected have mid-term expiry 
(3 to 6 months) and moneyness from10% OTM to 10% ITM. 
As for the Risk/Reward and Greeks groups of filters - they are always not set by default; you can use 
them for more sophisticated and fine-tuned scan. 
 
Let's see what comes up if you just press Search button, without changing any filters' values : 
 

 
 
After a short time (from just a couple of seconds to about two minutes, depending on the filters set) 
you'll see Results tab with the trades satisfying your criteria (top 5 trades with lowest Risk / Reward 
ratio are shown). The screen shows position legend, along with most important risk and reward 
characteristics. 
Clicking on the icon in the Details column (or, double-clicking in any place) opens the Details 
window: 
 



 
 
This window gives a more detailed view on the position: volatility (including IV bid / IV ask !), 
greeks, quote sizes, volumes etc. 
Here you can run a Risk Scenario and see how a position P&L will change under different levels of 
underlying price, implied volatility through time. This advanced functionality is described in a 
separate “Risk Scenario” section below. 
 
You'll find the following feature very useful if you are considering different option strategies and 
wish to compare them - a Pocket window. You can select the trades seeming attractive in Results 
window and "place" them into Pocket (Tools -> Copy to Pocket menu item or Ctrl+C hot key or 
this button ). The example below shows different types of "bearish" strategies (Bearish Vertical 
Spread, Naked Put, Short Naked Call etc.) in one Pocket window: 
 

 
 

Some hints on usage 
 

• If you are novice in option trading, you can use the very basic interface, without setting all 
the filters; we've tried to set reasonable default values for all the parameters 

• Do not try setting high probability of profit and low risk filter values at the same time - 
there's no free lunch 

• You can save filters' configuration to a file (File -> Save As or Ctrl+S) and load it later  
(File -> Open or Ctrl+L) 

• You can save options list returned by Scanner to a file (File -> Save As or Ctrl+S) and load 
this list later (File -> Open or Ctrl+L) 

• You can stop quotes updates and resume them through Run menu 
• You can delete "unnecessary" trades from results by Edit->Delete selection or Ctrl+D; 

you'll need to select the trades first, by checking the box(es) in the first column. 



• You can select the trades seeming attractive in Results window and "place" them into Pocket 
(Tools -> Copy to Pocket menu item or Ctrl+C 

 

Stock filters 
 
Stock filters allow selecting a stock universe, stock sentiment and options' cost level (IV Index): 
 
 

 
 
You can read more on how we calculate stock sentiment here: 
http://www.ivolatility.com/doc/StockSentimentRanker.pdf
 
You can select a custom stock list as a universe for scan. For small lists, you can just enter them into 
the Stocks text box to the right (comma delimited string). For the large ones, you need to create 
such a stock list (or lists) in our free My Favorites service 
http://www.ivolatility.com/manage_favourites.j This list will become available in the Stock 
Universe combobox then. 
 
If you press the Edit Filters button, the other (advanced) stock filters will become available. We'll 
describe all them in a separate section below. 
 

Option filters 
 
This section allows setting filters on options; it looks most sophisticated for Diagonal spreads: 
 
 

 
 

http://www.ivolatility.com/doc/StockSentimentRanker.pdf
http://www.ivolatility.com/manage_favourites.j


Here, you set Expiry and moneyness for "Leg 1" and difference (offset) in expiry, strike, and 
implied volatility for the "Leg 2". Here are the rules to determine "Leg 1" for a strategy: 
 
- if one option is bought, and other is sold - the bought option is "Leg 1" 
- if both options are bought or sold, the Call option is "Leg 1" 
 
Again, if you press the Edit Filters button, the other (advanced) option filters will become 
available. Stock and option advanced filters are described in a separate section below. 
 

 Stock and option advanced filters 
 
If you press the ‘Edit Filters’ button in the Stocks section, you'll see the following window: 
 

 
 
You can select any (or all) of these filters and press Apply button. If you do so, these filters will be 
added to the Stocks section of the Search window and you will be able to specify desired range for 
selected filters.  
Finally the ‘Long’ and ‘Short’ terms at the bottom can be used for advanced traders who would like 
to use such criteria as differences in long term IV index and short term IV index – suffix _S stands 
for short term, _l for long terms. So when you specify IVX Short term as 30 and IVX long term as 
180 you can apply a filter that will have a ratio of IVX 30d to IVX 180d in desired range (specified 
in the main Search window). 
 
Options section also has similar filtering window, the only difference is that there are 2 sets of filters 
for each leg: 
 



 
 

Below we describe what each of these filters means in detail. Note that if you wish to cancel some 
advanced filter, you need to erase the criteria. Just hiding the filter from the Stocks or Options 
section (using checkboxes in the Edit Filters window) is not sufficient! 
 

Stock advanced filters 
 
Here is the entire list of the advanced stock filters available: 
 

Filter name Meaning 
Price  current stock price 
Price % chg from close stock price change from close (in %) 
Volume % chg from close stock volume change from close (in %) 
Volume EoD % of 1m avg stock close volume to 1 month average ratio (in %)  
Capitalization stock capitalization, in $bln (in $1,000,000,000) 
HV_S - HV_L % difference between Short and Long term HV (in%) 
IVX_S- IVX_L % difference between Short and Long term IVX (in%) 
IVX_S / HV_S % ratio of Short term IVX to HV (in%) 
IVX_L / HV_L % ratio of Long term IVX to HV (in%) 
Total options volume % of EoD OI total option volume to total end of day open interest 

ratio (in%) 
Call/Put volume ratio total Call volume to total Put volume ratio (in %) 
IVX_S Call/IVX_S Put Call IV Index to Put IV Index ratio, Short term (in %) 
IVX_L Call/IVX_L Put Call IV Index to Put IV Index ratio, Long term (in %) 

 
Using these filters, you can select stocks with given change in stock price, volume, volatility etc. 
Also, you can monitor unusual option trading activity using Total options volume % of EoD OI 
filter. Finally, Call/Put ratio filters allow making an additional check for the stock sentiment 
(reading above 1 considered to be Bullish; however, too high reading may mean Overbought 
sentiment). 
 



Short and Long term in the above are set in the same Edit Filters window - you can select them 
close to options' expiries or using other considerations. By default, they are set to 30 and 180 
calendar days for IV Index (IVX) and to 20 and 120 trading days for HV (the closest to 30 and 180 
calendar days’ values).  

Option advanced filters 
 
Advanced option filters are available for each leg of the strategy and listed below: 
 

Filter name Meaning 
Bid option bid quote 
Ask option ask quote 
Ask-Bid % of stock bid/ask spread to stock price ratio (in %) 
Price % chg from yest option mid-price change from close 
IV option implied volatility 
IV % chg from yest option implied volatility change from close 
Volume % of OI option volume to end of day option open interest ratio (in%) 
Delta Delta greek 
Gamma Gamma greek 
Vega Vega greek 
Theta Theta greek 

 
Mind, that all these filters are per individual contract and independent of the quantity of contracts 
you are going to buy or sell. You can monitor change in option price and IV, assess option liquidity 
(Ask-Bid % of stock filter) and unusual option trading activity (Volume % of OI filter). Finally, 
for really fine-tuned scan you can set filters on each individual greek for the option contract. 

Calculation of risk / reward characteristics 
 
You can scan options' universe by the following important position characteristics in the service: 
 

• Capital Required 
• Risk/Reward 
• Risk/Cap Req 
• Max Return 
• Probability of Profit 

 
Here are their definitions and calculation methods: 
 
Capital Required - this is the initial investment required to open the position. Note, that this value 
is always positive - even if you are entering the credit trade. The amount of money blocked into your 
account (except credit, if any) is the Capital Required. We use this document from CBOE (R) site as 
a guideline for calculation of the Capital Required: 
http://www.cboe.com/tradtool/marginmanual2000.pdf
 
Risk/Reward ratio - is a ratio of "maximum" theoretical loss to "maximum" theoretical profit. We 
do not use absolute maximum loss and profit, since they are infinite for certain strategies and cannot 

http://www.cboe.com/tradtool/marginmanual2000.pdf


be used in calculations and scanning. We use a reasonable assumption that underlying price can vary 
within two standard deviations from its current value. We calculate "2 STD Profit" and "2 STD 
Risk" at expiry and use these values as proxy to max loss / profit. Same assumption is used for 
implied volatility. For Calendar and Diagonal spreads, we calculate risk at the short expiry, 
additionally assuming that option contract implied volatility can vary within two standard deviations 
too.  
These estimates give a feeling of how risky and profitable the trade is; if you need the exact 
estimates - you can always use the Risk Scenario functionality of our service. 
 
Risk/Capital Required ratio - is a ratio of 2 STD loss to Capital Required. This is an alternative 
way to estimate risk, comparing it with the initial investment, instead of maximum theoretical profit. 
 
Max Return ratio - is a ratio of 2 STD profit to Capital Required. This is the return to expiry, not 
annualized figure. 
 
Probability of Profit - an estimate of the probability that the trade will yield a profit. We use a 
simple model to calculate this value, p. Consider a case, when there are only two possible outcomes: 
you get maximum profit Pmax with probability p or maximum loss -Lmax with probability (1-p) 
("maximum" here stands for "2 STD" too). Assuming that position is fairly priced, your expected 
outcome should be zero, so 
 
Expected outcome = 0 = p*Pmax - (1-p)*Lmax 
 
From this we derive the probability of profit as 
 
p = Lmax / (Pmax + Lmax) 
 
This formula is just another illustration to the "no free lunch" concept: high probability of profit 
means either high risk (Lmax) or low maximum profit (Pmax) - or both. 
 
So, a general guideline to using these filters is as follows: do not try setting very high probability of 
profit and low risk to reward ratio at the same time; most probably, such a search will return 
nothing. 
  

Greeks 
 
You can filter the trades by their greeks; here are some hints of how are they calculated: 
 
Delta is shown in shares; in other words, it is a position value change in case when underlying price 
advances by $1. 
 
Vega is a position value change in case when option contract implied volatility increases by 1% 
(absolute, say, from 20% to 21%). We just sum vegas for two options without any adjustments for 
simplicity (the same is true for other greeks). 
 



Gamma is a change in Delta in case when underlying price advances by 1%. Large negative 
Gamma shows that a position will loose much under large change in underlying price and hence 
very risky. 
 
Theta is a position value change from today to tomorrow; it is negative for long option positions. 
Large negative Theta means that the position will loose in value ("waste") through time, all other 
factors being unchanged. 
 
Alpha is a ratio of Gamma to Theta. It compares profits (losses) due to underlying price move with 
losses (profits) due to option extrinsic value decay. Generally, you want large Alpha if your Gamma 
is positive and small Alpha if Gamma is negative. 
 

Risk Scenario 
 
You'll see this feature at the bottom of the Details page: 
 

 
 

It is a flexible tool for simulation of the position P&L and return under different levels of options' 
volatility and forward underlying price for fixed time horizons in the future. It is an invaluable 
tool allowing to check "what happens if" with your position under different market conditions. The 
following risk factors are taken into account: 
 

• Sensitivity of position value to underlying price and option volatility 
• Additional loss due to bid/ask spread 
• Short leg assignment risk  

 

How to use 
 
You can simulate P&L as a function of underlying price, time and volatility - just choose two of 
these as X and Y axes and simulate P&L and return as a function of these two (the third variable 
will be fixed).  You can also customize your axes step (as absolute value of percentage). You will 
see the matrix of P&Ls and returns like the one below: 
 



 
 

Some hints on usage: 
 

• Each cell in the matrix shows theoretical return (to date) and P&L 
• All the white background fields are editable 
• There are 3 ways to refresh the data: 

 
– automatically: check Refresh automatically box at the lower left corner; quotes and 
volatilities will be refreshed  from market feed then - so you'll see how your position risk is 
changing in real-time. 
– manually, with adjustment of axes values according to market movement (by 
request): the Refresh automatically box should be cleared, press Reset all button when 
you need to refresh the axes and P&L values. This mode suits for analysis of risks, having 
default values for underlying price and volatility. 
– manually, fixed axes: the Refresh automatically box should be cleared, press 
Recalculate P&L button when you need to refresh the data. This mode suits for analysis 
of risks using custom (edited by user) values for underlying price and volatility. 

 

Simulate assignment risk 
 
As you know a short leg can be assigned against you. We provide a convenient tool to simulate the 
short leg assignment risk (for a Short Straddle strategy for example): 
 



 
 

Some hints on usage: 
 

• Check the Simulate assignment risk box if you wish to deal with this risk at all 
• Choose what leg is assigned (if more than one legs are short) 
• For cash-settled (index) options check “Cash-settled at” box and enter expected forward 

underlying price 
• You may wish to emulate the cash settlement for stock options too (scenario when you are 

going to close resulting stock position resulting from the assignment). 
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