
RT Options Scanner 
 

Introduction 
 
Our RT Options Scanner allows you to search in real-time through all publicly traded US 
equities and indexes options (more than 170,000 options contracts total) for trading opportunities 
involving strategies like: 
 
- Naked or Covered Write Protective Purchase, etc.  
- Any complex multi-leg option strategy – to find the “missing leg” 
- Calendar Spreads 
 
Search is performed against our Options Database that is updated in real-time and driven by 
HyperFeed’s Ticker-Plant and our Implied Volatility Calculation Engine. We offer both 20-minute 
delayed and real-time modes. 
 
Unlike other search engines using real-time quotes data only our system takes advantage of 
individual contracts Implied Volatilities calculated in real-time using our high-performance 
Volatility Engine. 
 
The Scanner is universal, that is, it is not confined to any special type of option strategy. Rather, it 
allows determining the option you need in the following terms: 
 

– Cost 
– Moneyness 
– Expiry 
– Liquidity 
– Risk 

 
The Scanner offers Basic and Advanced Search Interfaces.  
 
Basic interface can be used to find options contracts satisfying, for example, such requirements: “I 
need expensive Calls for Covered Call Write Strategy. They should expire soon and be slightly out 
of the money. Do not care much as far as liquidity, but do not like to bear high risk.” 
 
This can be done in five seconds - set the search filters to: 
 
Cost -> Dear 
Moneyness -> OTM 
Expiry -> Short term 
Liquidity -> Any 
Risk -> Moderate 
 
and press the “Search” button. It is that easy. In fact, if your request is exactly as above, you can just 
press the “Search” button - these values are the default filtering criteria. 
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By default the search is performed against all equities covered by the scanner. You can limit this list 
by specifying a list of ‘your’ equities – comma separated tickers accepted. This filter is available in 
both Basic and Advanced Views. 
 

Basic View parameters 
  
Basic Version of the Scanner allows filtering by Cost, Moneyness, Expiry, Liquidity and Risk. Each 
of the filters below has the “Any” level of course - set the filter to it if you are not interested in a 
certain parameter. To narrow the search universe you may also specify a stock group (for example, 
“All USA”, “S&P 500 stocks”, “NASDAQ 100 stocks” etc) 
 

  

Moneyness 
 
Moneyness is a standard way to assess how near the option strike to current underlying price is. It is 
calculated as  
 
Calls: 100 % * (Underlying Price - Strike Price) / Underlying Price 
Puts: 100 % * (Strike Price - Underlying Price) / Underlying Price 
 
The Moneyness of zero means that option strike is exactly equal to underlying price - “at the money 
option”, ATM. Positive values are inherent in “in the money” (ITM) options (such options, if 
exercised, allow to Buy/Sell underlying for better price than the market one). Finally, negative value 
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of Moneyness means that there is no reason to exercise the option at the moment - that’s “out of the 
money” (OTM) option. Mind that Moneyness depends on the underlying price, and therefore 
changes in time: the Call option, once being ITM, might become OTM should the underlying price 
decline. 
 
The following levels are available in Basic Scanner: 
 
Deep OTM - Moneyness below -25 % 
OTM - Moneyness between -25 % and -10 % 
ATM - Moneyness between -10 % and +10 % 
ITM - Moneyness between +10 % and +25 % 
Deep ITM - Moneyness above +25 % 
 
Note that we use Moneyness range of -10%...+10% for ATM options - that’s because there can be 
no option contracts with strike exactly equal to underlying price at the moment. 

Expiry 
 
Different trades have different horizons and require different option expiries, right? Basic Scanner 
has a simple option expiry filter, with the following levels: 
 
Short Term – two-three nearest months 
Mid Term - two-three months to half a year till expiry 
Long Term – more than half a year till expiry 
 

Cost 
 
There are different possible measures of option’s cost - starting from just option price “as is” to 
complex model-specific parameters. We choose something in the middle, namely, option contract 
Implied Volatility. This popular measure of option cost is calculated using mean of bid/ask spread 
and shows option “extrinsic” (above par) value in a normalized way, comparable across different 
option contracts. You can find more details on Implied Volatility calculation and usage in our online 
Knowledge Base - http://www.ivolatility.com/help/4.html  
 
The following levels are used to discriminate dear / cheap options: 
 
Cheap - Implied Volatility below 25 % 
Normal - Implied Volatility between 25 % and 55 % 
Dear - Implied Volatility greater than 55 % 
 
These values reflect average actual market levels, up to our knowledge. 
 
One thing to be aware of - deep out of the money options can have large Implied Volatility values, 
and would be considered “Dear” by Scanner, although their price might be somewhere around $0.05 
per contract. This just means that these options do not cost even $0.05, that’s why treated as “Dear”. 
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Liquidity 
 
The liquidity value is even harder to assess, compared to cost, but this is one of the essential 
parameters, when considering the trade opportunity. Yes, the trade looks attractive, but would you 
be able to close the position on the winning price or would the bid/ask spread eventually turn your 
profit into loss? On the other hand illiquid assets might look more promising. We take quite a simple 
measure for liquidity, namely, end of day option contract volume. If it was high yesterday, probably 
the option is liquid and has a narrow bid/ask spread, so that you would be able to close your position 
quickly.  
 
The levels for liquidity are: 
 
Low - end of day option contract volume less than 50 contracts 
Moderate - end of day option contract volume between 50 and 500 contracts 
High - end of day option contract volume above 500 contracts 
 

Risk 
 
The Risk is a very complex concept but even the Basic Version of Scanner can help you to handle 
the Risk. Basic approaches to the Risk usually assume estimation of the so-called “Greeks” - the 
sensitivities of option price to different factors. The most commonly used “Greeks” are: 
 
Delta - sensitivity of option price to minor changes in underlying price 
Gamma - sensitivity to larger changes in underlying price (or sensitivity of Delta) 
Theta - option price decay with time 
Vega - sensitivity to Implied Volatility, or, in other words, to mispricing 
Rho - sensitivity to the market interest rates level 
Alpha - Gamma to Theta ratio 
 
How can all this be included into one value called Risk? We’ve chosen the single main risk factor, 
leaving the secondary ones out. Sure, it is a simplification, but still gives a good feeling of the Risk 
involved. 
 
If you do not have time to consider the details, a brief answer to what Risk is (in terms of our Basic 
Scanner) is as follows: 
 
if you intend to Buy an option - the Risk is Theta 
if you intend to Sell an option - the Risk is Gamma 
if not sure - the Risk is Vega 
 
Now, the detailed information of how this Risk measure was derived. As a first step, we’ve left out 
Delta, Rho and Alpha for the following reasons: 
 
Delta: no reason to account for this, since Moneyness parameter already gives a fairly good estimate 
of Delta. ATM options have Delta about 50 % (by absolute value), ITM - close to 100 % and OTM - 
close to zero. Just to make things clear, Call option having Delta of 100 % loses $1 for each $1 
decline in underlying price; Put option - the same for each $1 advance. 
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Rho: this parameter is traditionally left out when speaking of stock options; it affects only very long 
term options (LEAPS), and not that much, taking into account current low interest rates. 
Alpha: this is a risk/reward characteristic, rather than pure risk - so we left this out in our Basic 
version. 
 
The remaining factors (Gamma, Theta and Vega) are used as above. Indeed, if you buy an option 
contract, your main enemy is time decay - it is well-known that option prices decay with time, all 
other factors being constant. When selling option, the first thing to beware is fast option price 
increase when underlying price rapidly changes. But how do we determine if you going to  
buy or sell an option ? The secret is simple - we assume that you are going to buy cheap options, and 
sell expensive ones (Cost = Dear). If you select Cost level of “Any” or “Normal” (considering both 
Buy and Sell), the Vega risk factor comes into play - as you need to be sure that the pricing is fairly 
correct. 
 
The levels of Risk are as follows: 
 
1) when Buying an option (Cost = Cheap, so that Risk = Theta): 
 
Low - option price loses less than 1 % for a 1 day passed 
Moderate - option price loses less than 5 % daily 
High - option price loses more than 5 % daily 
 
2) when Selling an option (Cost = Dear, so that Risk = Gamma): 
 
Low - option price gains less than 0.25 % for a 1 % move in underlying price 
Moderate - option price gains less than 5 % for a 1 % move in underlying 
High - option price gains more than 5 % for a 1 % move in underlying 
 
3) when considering both Selling or Buying (Cost = Normal or Any, so that Risk = Vega): 
 
Low - option price changes less than by 1 % for a 1 % (absolute) change in Implied Volatility 
Moderate - option price changes less than by 10 % for a 1 % change in Implied Volatility 
High - option price changes more than by 10 % for a 1 % change in Implied Volatility 
 
Mind, that “Risk” field takes into account only the sensitivity to the main risk factor. The other risk-
related filters in Basic Scanner are Cost and Liquidity, described above. Indeed, low liquidity is a 
high Risk, and high Cost (high Implied Volatility) too. 
 

Advanced View Parameters 
 
The Advanced Search View gives you total search control while still using a very simple interface. 
You can select from a wide range of Stock’s and Option’s filtering criteria. Each filtering criterion is 
defined by the following fields (some criteria can have less): 
 
1. Filter Name (variable to filter by - like Implied vola) 
2. Filter Level (like Dear / Expensive, High / Low etc.) 
3. Filter Level modifier (like Absolute value, % of 1 month average etc.) 
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4. From field (Level low boundary) 
5. To field (Level high boundary) 
 
Combining Filter Name and Filter Level modifier defines the filtering criterion, for example: 
Filter name = Historical vola 
Filter modifier = in 1 year range 
 
Will produce the following filter 
Filtering criterion = HV in 1 year range 
 
Now you need to specify an acceptable criterion range. This can be done using the Level field. We 
have several predefined settings – such as “Low”, “High”, etc. This selection is translated into the 
From / To fields using the pre-defined constants, so you see the result of your choice immediately. 
Filter level combobox for each of the fields contains two special values - “Any” and “Custom”. 
“Any” means that there is no filtering by this criterion; “Custom” pops up when you manually edit 
From or To fields. 
 
Below we show the complete list of Stock and Option filters, available in Advanced View. We do 
not provide the pre-defined constants here, as they are easily accessible right in Advanced View 
interface. 
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Underlying Filters 
 
A full list of Stock filters, along with modifiers available, is presented below. Variable changing 
over the day is shown in bold. Depending on your subscription (real-time or 20-minute delayed) 
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these variables will be either realtime or 20-minute delayed data based. Formula / comment column 
specifies the exact formula used for the criterion. 
 
 

Filter Modifier Formula / comment 
Absolute underlying price, S 
% from yesterday S / S(yesterday) Underlying Price 
in 1 year range* (S - S(1yr min))/(S(1yr max) - S(1yr min)) 

Absolute underlying close volume, V EoD Underlying 
Volume % of 1 m average V / avg(V), last month average 

Absolute total close options volume, OV EoD Total Options 
Volume % of 1 m avg OV / avg(OV), last month average 

Absolute total close options open interest, OI EoD Options Open 
Interest 

  % of 1 m avg OI / avg(OI), last month average 

Absolute total close (calls volume) / (puts volume), CP 
EoD C/P volume ratio 

% of 1 m avg CP / avg(CP), last month average 

Absolute HV for 20 trading days (1 month), HV 

% from yesterday HV / HV(previous close) EoD Historical Vola 

in 1 year range (HV - HV(1yr min))/(HV(1yr max) - HV(1yr min)) 

Absolute Intraday IV Index for term 30 (1 month), IVX 

% from yesterday Intraday IVX / IVX(previous close) IVX 1m 

in 1 year range* (Intraday IVX - IVX(1yr min))/(IVX(1yr max) - 
IVX(1yr min)) 

IVX 1m / IVX 6m  Ratio of intraday 1m IVX to 6m IVX 

IVX 1m - IVX 6m  Difference of intraday 1m IVX and 6m IVX 
Call / Put IVX 1m 
ratio  Ratio of intraday IVX 1m Call to IVX 1m Put 

Absolute IV Index for term 30 (1 month), IVX 

% from yesterday IVX / IVX(previous close) EoD IV Index 
  

in 1 year range (IVX - IVX(1yr min))/(IVX(1yr max) - IVX(1yr min)) 

EoD Relative vola Absolute IVX / HV 
 

 8



* - resulting figure can be outside of 0..1 interval due to the fact that intraday value is compared 
against historical high and low (when new high or low record is set). 
 
Examples: 
 
1) Stock price advances more than by 5 % from end of day value: set Stock price modifier to “% 
from yesterday”, “From” to 105. 
 
2) Stock close volume larger than monthly average by 20 %: set EoD Stock volume modifier to “% 
of 1 m avg”, “From” to 120. 
 
3) EoD IV Index less than 25%: set EoD IV Index modifier to “Absolute”, To to 25. 
 
4) 1 month IV Index is at least 10% more than 6 months IV index (when looking for Calendar 
Spread): set IVX 1m - IVX 6m “from” field to 10. 
 
 

Option filters 
 
A full list of Options filters, along with modifiers available, is presented below. Variable changing 
over the day is shown in bold. Formula / comment column specifies the exact formula used for the 
criterion. 
 
 
 

Filter Modifier Formula / comment 

Type   Call / Put 

Expiry Absolute expiration month and year 

Absolute mean of the option contract bid/ask, C 

% from yesterday C / C(yesterday) Price  

% of stock C / S, S - intraday stock price 

Absolute option contract implied vola, IV 
% from yesterday IV / IV(yesterday) Implied vola  
in IVX 1 year 
range (IV - IVX(1yr min))/(IVX(1yr max) - IVX(1yr min)) 

Moneyness, % Absolute 1 - K / S for Calls,  K / S - 1 for Puts (K = strike) 

Absolute option contract absolute value of Delta; non-negative 
input is expected for both Calls and Puts Delta  

% of price Delta * S  / (100*C) 

Gamma  Absolute option contract gamma, Gamma 
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% of price Gamma * S^2 / (10000*C) 

% of delta Gamma * S / (100* Delta) 

Absolute option contract premium decay, Theta; non-negative 
input is expected  

% of price Theta / C 
Theta 
  

% of delta Theta * 100 / (S* Delta) 

Absolute this option contract vega, Vega 

% of price Vega / C Vega 
  

% of delta Vega * 100 / (S* Delta) 

Absolute Gamma / Theta; non-negative input is expected Alpha 
  Normalized Gamma * S^2 / (10000* Theta) 

Absolute option contract volume 
Volume 

EoD Absolute option contract EoD volume 

Bid Size  Intraday best bid size (liquidity indicator) 

Ask Size  Intraday best ask size (liquidity indicator) 
 
 
Some examples of the filters usage: 
 
1) Option premium is at least 10 % of the underlying: set Price modifier to “% of stock”, Level low 
Boundary (“From” field) to 10. 
 
2) Option premium decays less than 2 % daily: set Theta modifier to “% of price”, Level high 
boundary (“To” field) to 2. 
 
3) Risk of option price decay due to Gamma is not greater than that due to Delta: set Gamma 
modifier to “% of Delta”, Level low boundary (“To” field) to 100. 
 
For the Greeks (Delta, Gamma, Theta, Vega, Alpha), in addition to “Absolute” Level modifier, we 
introduced “% of price” and “% of delta” modifiers. These normalized criteria help to understand 
percentage change in option price, and to compare the change magnitude with sensitivity to 
underlying price (Delta). The following increments are implied when using normalized Greeks: 
 
- Delta, Gamma - 1 % of underlying price 
- Theta - 1 day 
- Vega - 1 % (absolute, like change from 20 % to 21 % in implied vola) 
- Alpha - 1 day for Theta and 1% of underlying for Gamma 
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Mind, that all the Greeks in filters are entered by their absolute value. So, if you are looking for Puts 
with Delta between -0.75 and -0.5, just set Level boundaries range to (50, 75). 
 

Scanner usage tips 
 
Though the application interface is pretty intuitive and most likely you won’t need any additional 
usage instructions here are some hints you might find useful. 
 

General Hints 
First, you can position ‘Monitor’ screens within a single frame (accessible by the tabs at the top) or 
you can have every screen open in a separate window. To switch back and forth between this two 
modes just click  /  buttons (or use the ‘View’ menu). 
 
The ‘File’ menu can be used to open a new Search or Monitor window. You can also Save/Load a 
Search profile - all your search criteria will be saved into your local drive – do this from File menu 
or use  /  buttons. There is an ability to Save and Reload the list of the option contracts present 
in current Monitor screen. This can be done through File menu as well (or  /  buttons) 
 
Since permanent data updates might generate considerable network traffic you might want to 
‘freeze’ updates for some time – stop/play button ( / ) serve exactly this purpose - or ‘Run’ menu 
item. 
 
Finally, you can rename any of the ‘screen’ tabs – select the screen you wish to rename and click the 
Rename menu item from the Edit menu. 

Search Screen Hints 
We’ve already described the Search screen variables above. You might consider useful a small 
checkbox at the top of Basic Search screen – ‘Auto-apply changes to the Advanced View’. If you 
click on that checkbox and switch to the Advanced Search Mode you will have values from the 
Basic screen used as default values for the Advanced Screen – that’s actually a simple way to 
understand what our default search profiles mean. Finally, the very bottom field in the Advanced 
view can be used to exclude contracts where the bid/ask quotes has not being updated for some time. 
Remember that since this version of the scanner is based on the 20-minute delayed data any value 
less than 20 will produce an empty result 
 
Search profile criteria (Basic or Advanced) can be saved to your local drive for subsequent reload – 
just use File->Save Profile menu item (or Ctrl-S). Saved Profile also keeps track of the selected 
columns to be shown as a search result. 
 

Monitor Screen Hints 
Monitor Screen displays options contracts that match your search criteria. You can have several 
screens (up to ten) with different set of options contracts shown simultaneously. Each screen can 
have up to 1200 option contracts. Maximum number of options contracts to show at one time (across 
all screens) is 3000. 
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It is also possible to add options contracts to your watch-list using contracts selection filter at the top 
of Monitor screen. You can add either selected options of the specified underlying or just add 
options contracts directly by specifying an option ticker. 
 

 
 
Left area of the Monitor screen lists all available columns (the ones in bold are updated in real-
time). ‘Delete’ column allows you to mark an option contract for deletion (Edit->Delete or Ctrl-D). 
Quote time indicator (a small ball with different colors) gives you an idea of how ‘fresh’ current 
option contract data is. Green ball means the quote is less than 40 minutes old, yellow is for quotes 
in 40 to 1h 20min range and the rest is marked as red. 
 
Most of the fields are pretty self-explanatory. The ones with EoD prefix are variables as of previous 
close. You can combine both Intraday and close values on one screen for simpler comparison. EoD 
Relative Vola is a standard term we use on Ivolatility.com – this is the ratio of 30-day IV index to 
30-day Historical Volatility (i.e. “EoD 1m IVX”/”EoD 1m HV”).  EoD C/P volume ratio is a stock 
characteristic – a ratio of EoD total Calls volume to EoD total Puts volume. 
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You can add and remove fields to display, new field will be added as a first column – you can drag 
it with a mouse to a position you like (just drag the column title). 
 
To save the list of options contracts to monitor into your local drive use the File menu (Save List or 
Alt-Shift-S).  
 

Your feedback 
 
We welcome your comments on the RT Options Scanner – we will certainly use them as ideas for 
subsequent versions of the Scanner. We will be adding more features to our scanner in coming 
months to help it make as useful as possible. Our email address is support@ivolatility.com
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